• Join Premium And Save!
      Join Premium And Save!
    • Save up to 15% off your Jaguar insurance!
      Save up to 15% off your Jaguar insurance!
    • Large Selection Of Jaguar Parts
      Large Selection Of Jaguar Parts
    • Club T-Shirts and Merchandise
      Club T-Shirts and Merchandise
    • Share Your Experience
      Share Your Experience
    • Over 3000 Jaguar vehicles for sale
      Over 3000 Jaguar vehicles for sale



Wayne O

Collected it yesterday and a few Q`s

Recommended Posts

Ok let me start by saying how much I love this car, yep I have the GRIN even considering the hassle it has caused me. 

This car to me has cost a fortune and i want it top notch order, I was expecting it to be nice clean and shiny when i collected it but it had been valeted but you can tell it had been driven as dirt up the rear arch area of the front wheel from road spray. What am I on about there are worst things to come. 

Well then,short story 

I bought it and took it home but to only get 6-7 miles and it started to play up and hard to start ( stopped for a drink and meal and fuel ) and then cut out all together. 

Dealer came out thinking it was the EGR sticking and blanked it off but then and found that number one injector was at fault and put another one in, not new one. And leaving the EGR blank in place .It started fine and ran fine for the first 80 odd miles home. 

Now i set the CC to 75mph and ran smooth as a pint of good cider on the first sip on a friday night.

Now i came to find a prat up my backside in the far side lane while i was overtaking so i decided to give a little more welly, not a great deal mind you.

It near cut out but found it more like limp mode as power dropped right back and i managed to move over to the hard shoulder..................had a moment and turned the car off and left in the thought it would reset it self which it did.So off i go again. 

Point now is to sort this, well i understand the problem before i talk to the dealer tomorrow. I want a rough idea what is wrong, not that i dont trust him, seems a decent bloke.   

Now what i have found is that the orange engine managment light is on all the time, due to EGR blanked off ?

But when you give it welly to say overtake the orange coil light come on flashing and there is the loss of power until you turn the car off for a minute and then its stats fine and drives fine. 

 

Also one sort of small thing. when i set the CC to sat 60mph i ma sure that on at least 3 occasion it has gone over the speed by a good 10mph. is that common ?

 

I still love the car though

 

any advice appreciated 🙂

 

cheers

 

Wayne

 

20180610_145252.thumb.jpg.e6b27bcbae9e641ef28ab67f33f10477.jpg

Share this post


Link to post
Share on other sites
 

How did you get on with the car , the injectors need to be coded so did the Dealer re-code the secondhand injector.

It could be that you need a full set of injectors, or it could be a sticky turbo or the actuator at the Turbo. You'll see an arm at the Turbo you can remove the circlip and the arm should move quite freely, be careful not to drop the circlip. Some members put in Forties injector cleaner in the fuel tank and use Premium Diesel is it a manual or auto if it's an Auto with a DPFILTER you should use a Low Ash C1 engine oil ( WSS M2C 934B ) is the number that is not mentioned in the Handbook.

When you gave it some weekly you could have blown a hose off the  EGR to Intercooler or the Turbo to Intercooler, you should check the jubilee clips on these hoses as the clips tend to rust and then the hose gets blown off.

Share this post


Link to post
Share on other sites

Welcome to the club, Wayne.

Tom has given you a few good suggestions.

A quick check on Vehicle Smart tells me the your car is a 2.2 litre model and there is a Diesel Particulate Filter on your car.

Blanking off the EGR valve trying to avoid the problem of a sticky valve, which an additive could easily solve.   It is certainly a fuel problem and I concur with Tom that it could be the injectors.  Sometimes it can be a easier fit of a bit of kit could be loose or damage  --and as Tom said loose connector or a damaged hose.

Let us know how you get on.

Regards

Peter. 

Share this post


Link to post
Share on other sites

Hi Wayne and Welcome,

I think you will need to get hold of a suitable OBD2 code reader, or your dealer does, to get to the bottom of these problems. The advice Tom and Peter have already provided is correct but I would add that it is never a good idea to blank off the EGR - the car will almost certainly fail its next MOT - and doing so can also generate many other problems as I understand it.

In the short term it may be an idea to post a thread on this site asking if there are members near to you who have a code scanner and are willing to help you out. There should be a few at least. For the long term though you will benefit by getting hold of one for yourself.

Cheers,

Steve

Share this post


Link to post
Share on other sites
59 minutes ago, cubist said:

Hi Wayne and Welcome,

I think you will need to get hold of a suitable OBD2 code reader, or your dealer does, to get to the bottom of these problems. The advice Tom and Peter have already provided is correct but I would add that it is never a good idea to blank off the EGR - the car will almost certainly fail its next MOT - and doing so can also generate many other problems as I understand it.

In the short term it may be an idea to post a thread on this site asking if there are members near to you who have a code scanner and are willing to help you out. There should be a few at least. For the long term though you will benefit by getting hold of one for yourself.

Cheers,

Steve

As Steve says check for any codes, and with the 2:2 auto it is advised not to Blank the EGR Valve and only use genuine jaguar oil and fuel filters.

We await for your reply on how you are getting on, usually members change all fluids and filters after buying a car and then they know everything is as it should be also with having a Diesel Particulate Filter most member's just add 5:5 litres of oil instead off 6 litres this is in case a Regeneration Fails .

Don't be put off by what i've said because they're great cars, you'll hear a lot of comments about the DPFilter but in the five years I've owned this x type which is my third i have not had any problems with the DPFilter. The only thing is knowing when a Regeneration is taking place, what i notice is the engine revs are about 150 to 200 Revs higher when the engine ticking over if this is happening don't switch the engine off but instead take the car for a 20/30 minute drive. Other members notice a louder than usual exhaust noise as if there's a hole in it and also you can see a Lower miles per gallon.

Regards Tom.

 EGR

Share this post


Link to post
Share on other sites

Hi guys, sorry for late repy and thanks for the interest and help on this as it is getting my head banging and what to do with it.

 

Story so far

Yesterday i called the dealer and told him again what was happening. His suggestion was to take it down to him which is a 200 mile round trip. Just to see if he can get into the system.

I said nope, i will go to my local garage who i trust, i dont do garages at all and in all the 20 odd cars i have had have never been to a garage for work to be done but for an MOT.

On way to the garage i tried to get it into limp mode, and well sods law it did happen lol.

Well at the garage he plugged it in and found well over 30 fault codes on the car itself and he then cleared them for me. He tried to get into the engine but for some reason he couldnt connect the diagnostic gadget. 

Next step was to go to the local diesel tech guys. Hi Tech diesels in Bury. He said to book in and see what they can do, i mentioned about the garage not being able to connect with the car engine. He said he will have a go before i book it in for me. Now he couldnt get in either. This is a dam good diesel spec place i went to and know there stuff.

The diesel chap said to `get rid` lol

then after a chat he suggested to check the fuel filter for metal shavings. these can be the sign  of the injector pump failng and blocking the injectors etc etc

 this is what i found after i did it. and it was meant to of been serviced 500 miles before i got it and i have put 500 miles on it in the four days i have had it.

First pic of what was drained off, then the second is the steel filling that i magged out of the muck, nice long shiny steel splinters.20180613_173130.thumb.jpg.88c7897c0ac384fee04d827822b359d8.jpg20180613_173140.thumb.jpg.600af5bf3717726e81c3de59dd2d2b2d.jpg

 

I changed the filer with a new one tonight and went for a spin, still going into limp mode. It happens when i am running in 3rd gear at just under 2k rpm then accelerate hard to just over 3k rpm . Much the same as at any speed upwards of that. Maybe thats why i could get it to limp last night as nowhere to get the speed/power up.

 

Well the dealer has said he cant see it being the pump as in over 2k Mondeos he has worked on he has never had to replace a injector pump. 

 

He has offered me a 12 month parts and labour warranty

 

 

Ok shortend this post a si have been on the phone half way through this post to a chap that has worked on Jags for many many years and X types are/was his bread and butter, and he has just near as dam said what you guys have said above.

90% have said get rid so that the way to go. 

 

Dam gutted but atleast i have lost out much but for £100 to collect the car. 

 

On look out for another car now. I have been put off Jags 😞 

 

Share this post


Link to post
Share on other sites

Claws has a nice S Type, Wayne.  He is looking to sell it. 

Share this post


Link to post
Share on other sites
7 hours ago, Old Peter said:

Claws has a nice S Type, Wayne.  He is looking to see it. 

Morning matey. 

I need an estate for the space. and on finance.

ill havva look this around weekend as i need one quick`ish , like in a week. 

Share this post


Link to post
Share on other sites

Hi Wayne,

What a bl$%^&y shame.

My guess would be that some/most/all the fun lines and injectors are fouled with that rubbish. Sorry but I have no suggestions other than a complete strip and clean of the fuel system starting at the pump but I would be looking for the dealer to do all that - if I trusted him.

Don't let this one bad experience put you off the marque, more often than not the real culprit is poor maintenance or repeated thrashing by the driver.

Cheers and Good Luck

 

Share this post


Link to post
Share on other sites

we spoke today and he is full of it. more lies. I almost fell for keeping it. 

 

Ok plan is he can now 100% stick where the sun dont shine.

 

It was sold as serviced 140000 but then the car has not done more than 70 miles since 2016 as GUV website states that on the MOT check. 

 

And i believe the service was done around 700 miles ago was not done really

 

 

 

20180615_181831.thumb.jpg.dd8d4cb2e534393b4a1fa72473f64f08.jpg20180615_181856.thumb.jpg.4752b9530637080c97f899299a76fa5d.jpg

 

As soon as i have this sorted i am after another, but the exact same model SE version, colour interior the wheels the lot, so if anyone sees one please tell. 

Wayne

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now