Recommended Posts

Hi all

I'm new to JOC an I've got a problem with my 1998 XJ8 gear box. When I select "D" there is no drive although the engine is running. If I press the throttle the engine revs and after a sudden jolt the car moves. Until recently, once the drive had started, there was no further problem but now i can only moved slowly initially building up speed slowly until the car is in full motion. Reverse is fine but has in the past done the same. I thought I had, perhaps, lost hydraulics but I've never seen any oil spots on the ground. I was informed that the gearbox is sealed for life. Does this mean that the car is at the end of its life?

Incidentally I had a LPG conversion about 15 years ago and I think its the best thing I ever did.

Any ideas on the gearbox problem would be gladly received.

Share this post


Link to post
Share on other sites
 

Correction.

On reading my post I realized I may have misled you folks. I have two XJ's. The one with the faulty gearbox is a 1998 model which I have owned for nearly 20years.

The latest addition is a very nice executive.

Share this post


Link to post
Share on other sites

I wonder if it is low on fluid or just needs changing?

Would definitely take it to a transmission specialist to check it over

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...