Frankiew

XF Turbo Issue & Solution

Recommended Posts

Hi all, new the forum, if i'm posting in the wrong place please let me know.

I have a 2009 XFS. It's going in to restricted performance when it hit approx 3500 rpm. It clears when I turn the car off and on.

I have taken it to a garage and they have replaced the turbo shut off valve but I'm still getting the same issue. It's been back and they have told me the secondary turbo has gone and needs replacing.

Has anyone else had a similar issue? 

Can anyone recommend a garage near nuneaton?

Cheers

Share this post


Link to post
Share on other sites
On 8/15/2019 at 11:06 AM, Frankiew said:

Hi all, new the forum, if i'm posting in the wrong place please let me know.

I have a 2009 XFS. It's going in to restricted performance when it hit approx 3500 rpm. It clears when I turn the car off and on.

I have taken it to a garage and they have replaced the turbo shut off valve but I'm still getting the same issue. It's been back and they have told me the secondary turbo has gone and needs replacing.

Has anyone else had a similar issue? 

Can anyone recommend a garage near nuneaton?

Cheers

Hi 

I am new here too after just buying a 59 plate x type 2.2 diesel. On the way home from the garage 50 miles or so i stopped at the services when i re started as i put my foot down on the M1 i got flashing heater light and gearbox fault message car went into limp mode

Taken it to an Indie Jag Specialist and he has diagnosed Turbo Actuator has failed causing the car to think there is an issue with torque selector He is replacing the actuator next week which he tells me will clear the other fault. He wants £150 for the actuator fitted which seems ok to me 

Dont know if this helps?

Share this post


Link to post
Share on other sites
On 8/16/2019 at 6:54 PM, chris s said:

Taken it to an Indie Jag Specialist and he has diagnosed Turbo Actuator has failed causing the car to think there is an issue with torque selector He is replacing the actuator next week which he tells me will clear the other fault. He wants £150 for the actuator fitted which seems ok to me 

Can you please let us know if this has this resolved the issue(s), thanks

Share this post


Link to post
Share on other sites

Hi Yes sure

The car goes in tomorrow ( Tue 20th Aug ) for repair and full service. Once i collect the car i will let you know of the outcome 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi Collected the car this afternoon and up to now.....the new turbo actuator has cleared the problem.

He tells me the reason gearbox fault message appears is because the car thinks there is an issue with the torque selector as the car will not go in to top gear, however this is because the car is in limp mode.

On EBay they are around £80 he has charged me with labour £150 So anyone with similar issues may want to try this first and expect to pay around this amount

Hope this may help 

 

  • Like 1

Share this post


Link to post
Share on other sites

That's great news and thanks for feeding the information back, it's certainly a great help for anyone with this issue.

Happy Motoring !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...