Recommended Posts

Hi all in new to this site but I'm hoping someone can help me with my JAGUAR 1982 XJS V12.

I have purchased the vehicle 3 months ago as a barn find in the hope to restore her...I seem to be having a fuel problem, the injectors have a permanant positive to both sides of the plug?? This can't be correct can it?

Share this post


Link to post
Share on other sites

Hi Andrew....welcome to the Forum

That is correct for the injectors to have a 12v permanent feed as the they are triggered by an earth feed from the ECU (more stable way of firing an injector).

I would check the system and fuel pump relays first

Good to have you onboard

Cheers, Trevor

Share this post


Link to post
Share on other sites

Thanks Trevor...but I have 12v on both pins? Shouldn't  it just be on just one pin?

Regards Andrew 

Share this post


Link to post
Share on other sites

I would say that you possibly have a bad earth or a short circuit to ground

Either one or more of the injectors are defective (one I could understand, even maybe two but anymore than that there has to be a common fault)...or... there is a short to earth on the loom feeding the injectors. If this is the case then you would have the injectors running constantly.

If they are not running constantly then it must be a relay or ECU fault which is feeding power through the earth feed (probably a poor connection or corrosion).

Easiest place to start is the System/Main Relay

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...