Alan Matty

Tyre Pressure Sensors

Recommended Posts

A few months ago I bought a 2015 Jaguar XF, Everything is great apart from the tyre pressure sensors

Almost everyday when I start the car, the display tells me I have low pressure in the tyres and when I am driving around the display is continually showing either the left or right rear side tyre pressure is low, its constantly flicking between the two

I've checked the pressure with a few gauges and everything is fine

Any help please

Thanks

 

Share this post


Link to post
Share on other sites

Hi Alan....welcome to the Forum

You could try just a couple of psi extra in each tyre to see if this keeps the sensors happy.
Always ensure that the pressures are checked when they tyres are cold and 2 psi extra won't affect the handling that much.

Let us know what you find

Cheers,  Trevor

Share this post


Link to post
Share on other sites

I'm led to believe that each sensor has a battery fitted to them inside the tyre and may need changing after 4 year's, and i've also heard that they need to be working when the car goes in for it's Mot.

I've got them on my XF and one was acting up, but it seems to have settled down now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...