Roy1211

Members
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Roy1211

  • Rank
    Member

Profile Information

  • First Name
    Roy
  • Gender *
    Male
  • Jaguar Model
    XF
  • Year of Jaguar
    2008
  • UK/Ireland Location
    Worcestershire

Recent Profile Visitors

387 profile views
  1. Roy1211

    Vibration

    Up date on the vibration on my beloved xf, I took the car yesterday to my local exhaust and battery shop as a last resort to check my Wheels and to my dismay found out I have 2 buckled wheels 😩 after all the time she has spent in the garage only to come to the conclusion I have knackered wheels, so now I’m looking for a good and straight set I can buy, has anyone got a set I can buy ????? Mine are 18 inch HELP 👍👍👍👍
  2. Roy1211

    Vibration

    Vibration up date returning from work the other night stopped to put some fuel in, come to start it and the engine just keeled spinning over sounded like no compression I thought oh nooooio cam belt but after about 5 mins of trying to start it it fired up, drove it home with no problem??? I thought that was the end of my beautiful xf, I’ve just had a walk up to my local garage and he said to try and get it to him, after 3 days of the jag being left I came back from garage and thought I’d try her one more time, jumped in pressed the button and she fired straight up with no problem at all so now I’m confused as to the fault 😩 I thought the cam belt had gone but it can’t have as now it’s fine ?? she just sounded like she had no compression at all but now seems ok 😩 I hope this post will shed a light on anybody who’s had similar issues as me will keep you all posted as to the outcome Roy
  3. Roy1211

    Vibration

    Thanks Jon but had the wheels and tyres all checked and all good, was reading a few posts on here and sounds like it’s a bit of a xf problem, when it goes the the garage ( again) next week I’ll ask them if they can to check the prop and the rubber doughnuts ??? I’m just under £700 trying to sort this out so I’m to far in now to stop investigating the problem, I just want it to run like a Jaguar should thanks again Jon for your reply
  4. Roy1211

    Vibration

    Hi guys I wonder if anyone has had the same problem as me with my beloved 2.7 xf 58 reg, the problem is when the car gets to 60/70 mph I get a vibration it’s very difficult to describe, ive had new disks & pads on the rear ( still the same) I’ve had the wheels balanced twice ( still the same) it’s going back to the garage next week to have the front wheel bearing changed although the garage says it’s only very very slightly play in it but thought I’d have the front disks & pads changed at the same time, has anyone had this problem with the xf or have I got the only xf out thire with this problem?? it is a real pity as I love the car but this problem is starting to get expensive to try and solve, I'm hopping someone will give me some help on this thanks guys Roy
  5. Quick update my friends I took the sat nav dvd disk out and low and behold the wrong disk had been inserted, I put the correct disk in as I’m in the uk not abroad and it’s all good now the keys work when I enter a uk post code address, a big thank you to all of you that helped me cheers 👍👍👍👍👍👍👍
  6. Hi mate thanks for that, the sat nav is set for the uk I can’t understand why the only key on the post code that is working is the 0 key all the others are faded out, the sat nav is working as it asks me to agree st the start of the opening screen shot it also displays where I am ( Evesham ) but that’s it 😩 I am totally confused.com but thank you for your reply, if I re install the dvd will that help ???? I’ll will update my details of my new car thanks
  7. Thanks mate but the sat nav is different in the xf, the pic you show is from the x type sat nav I think but I know what you mean and I thank you for your reply cant be a lot wrong with it as it shows and works as a sat nav JUST can’t input a post code address it’s really annoying again I thank you for your kind reply hopefully I’ll get it sorted cheers Roy
  8. Hi mate thanks for that, the sat nav is set for the uk I can’t understand why the only key on the post code that is working is the 0 key all the others are faded out, the sat nav is working as it asks me to agree st the start of the opening screen shot it also displays where I am ( Evesham ) but that’s it 😩 I am totally confused.com but thank you for your reply, if I re install the dvd will that help ????
  9. Ok thanks for that I’ll try it tonight thank you for your time
  10. Hi mate thanks for that, the sat nav is set for the uk I can’t understand why the only key on the post code that is working is the 0 key all the others are faded out, the sat nav is working as it asks me to agree st the start of the opening screen shot it also displays where I am ( Evesham ) but that’s it 😩 I am totally confused.com but thank you for your reply, if I re install the dvd will that help ????
  11. Hi mate thanks for that, the sat nav is set for the uk I can’t understand why the only key on the post code that is working is the 0 key all the others are faded out, the sat nav is working as it asks me to agree st the start of the opening screen shot it also displays where I am ( Evesham ) but that’s it 😩 I am totally confused.com but thank you for your reply, if I re install the dvd will that help ????
  12. Please help someone? i recently sold my x type and bought a xf 2.7 58 plate, I love the car but I’m having problems with the sat nav, when I try and enter a post code for an address the keys on the screen are faded out and I can’t enter nothing😩😩😩 do I have to reset anything please help someone thank you in anticipation 👍 cheers Roy
  13. Up date, just got jag back from the garage, re start up problem new glow plugs fitted all seems fine now, thanks for all your help guys ps All so fitted new anti roll- bar bushes ( think that’s a common problem on jags) but all good now cheers guys for your help
  14. Thank you for that, the start up problem is ALL THE TIME ( hot or cold engine) seems to run fine, But thanks again I’ll run it to my local garage Tuesday ( I work nights ) cheers
  15. Thanks for that but I did have a diesel before this, I do wait for the glow light to go out before starting, she does fire up but the revs seem to take to long befor normal rpm, if I need a set of glow plugs how much at garage will that cost ? I just need her fixed thanks for your help