Jon Hyde

XF-S 2011 interior lights randomly coming on

Recommended Posts

Sorry if I've mentioned this before (age is a curse!), but does any other XF owner (2011-ish) have any experience of the interior light(s) above the windscreen and in the back, lighting up randomly when driving along?. In my case, it's mainly the centre light (with the back ones) and occasionally the one to the left of the centre one as well. After a few touches on the lens, it/they go off, but I simply wish they didn't light up in the first place!

Any suggestions for a cure gratefully received!

Thanks,
Jon

Share this post


Link to post
Share on other sites

Hi Jon,

I’m afraid I can’t really help, but weirdly I had exactly that happen to me yesterday in my 2011 XF. It was daytime so not a serious issue, but it’s never happened before (that I’ve noticed) and I’d just seen this post earlier.

I’ll keep an eye on it and see if it persists. I really am no expert so I can only hazard a guess, but as it was the first decently warm day this year, maybe a sensor or something is expanding with age and heat possibly.

Hope someone on here has experienced (and fixed) this!

cheers

Ian

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, Ian.

I would mind if it was an everyday thing, but it's completely random. Of course they can by (eventually, after a couple of touches), be switched off, so it's really just an annoyance.

Cheers,
Jon

Share this post


Link to post
Share on other sites

I think you may be onto something with the heat thing! I've never had it happen at night!

 

Hmmmm

Share this post


Link to post
Share on other sites

Brilliant!

I was considering swapping to LEDs for whiter light but thought they might make the problem worse.

I think I'll just go for them after reading that. Can always get the circuit board swapped later if LEDs don't cure it.

Thanks for sharing that, 
Jon

Share this post


Link to post
Share on other sites

I think I’ll be doing the same. Hope this leads to an answer!

Cheers

Ian

Share this post


Link to post
Share on other sites

just seen your post, while researching a usb connectivity issue.

I've had that happen a couple of times while driving along, touched the light and thought nothing more of it, but I have been having headlight issues.

When I first bought the car 2011 XF-S (60), it had had a HD Led conversion which when I took it for an MOT had to be changed because the law changed last April.

So I had the conversion ripped out and put 'night breakers' in but then every few months one of the bulbs would blow and thinking about it now when I changed the bulb I had the random interior light experience!! (Now running on the standard bulbs for around a month with no issues, think it might be a voltage/ampage thing).

No idea if this makes any sense to anyone, but just thought i'd add my story.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...