Steham

Sluggish x type 2.2 diesel

Recommended Posts

Hi, just acquired an x type 2.2 diesel, and it's sluggish on initial pull-away.

When I got it, the EML light was on, and was told it was because the EGR valve had been removed. I've had a look, and yes, there's no EGR valve, there is the loose plug which WOULD have been connected to the EGR valve, had it been there. Where the EGR valve should have been is a piece of metal pipework, connecting to the normal large bore tube that goes to the intercooler???

There doesn't appear to be splits in the large rubber tube/hose, but it DOES appear to be oily around where it connects to the intercooler.

Any ideas what to do to get this old girl going a bit better?

I will Inspect the large hose again tomorrow to make sure it's free of splits.

Help, peeps???

Share this post


Link to post
Share on other sites

Hi Steve

If it is losing boost pressure then you will definitely hear it hissing and blowing.
The hoses should swell when the revs are raised enough to create boost pressure from the turbocharger.

Other areas to investigate would be the EGR being removed and the Engine Management in limp home mode. This could be rectified by refitting the EGR and using a blanking plate (with small hole in the middle) which still allows the system to recognise an EGR and run normally (albeit with no functioning EGR to block up).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...