ash73

headliner replacement electrical problems

Recommended Posts

First of all, hello I'm a newbie and I own a 2004 3.5 V8 XJ.

 

I had the headlining replaced today, and there are a couple of problems.

 

1. The auto wipers are no longer working. I checked the sensor and they didn't reconnect it, because they fixed the wiring too far into the headlining and it won't reach!

I'm wondering if a female/male adapter might just be enough for it to reach, if I can find out what connector it is.

Or I could buy another plug with longer wires already attached, and use it to extend the existing wires.

Does anyone recognise the connector type?

 

2. The three lights in the overhead console are no longer working. I haven't investigated yet, but the fuse is ok, and the rear grab-handle lights work (and can be switched on via the centre button on the console), but the lights on the console don't work with the buttons or when the door opens. It must be another connection issue somewhere.

Any suggestions?

 

I'll chase up the fitter but I expect I'll need to resolve it myself, seems to be the way these days.

TIA.

connector1.jpg

connector2.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...