Stype tel

Poor performance warning

Recommended Posts

Morning all. 

I have a 1997 xk8. Was running fine up till a week ago. She has been standing for a wile in the garage, but now I got her out I have the warning message of poor engine performance.   Battery is in good condition and has been fully charged. It does hold the charge.  I have plugged a reader in and it says it's the coils.   Could anyone confirm this or could it be something else.    Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Watch this thread as I have the same 97 XK8 poor performance warning light comes on.  Diagnostic reading showed problem was in Group 2 or Bank 2 – passenger side of engine.  This would shut down half the engine after about 3 minutes from engine start.  My mechanic's 1st option was to rule out an ignition module fault ( common in older model Jags and an easy check)   so he swaped them both around to see if it would cause Group 1 or Bank 1 side of the engine to shut down but it didn't so we have thus far ruled out the ignition modules as being the culprit.  Next Sunday, weather permitting, he is going to dig into the electrical side of things so I'll keep you updated.  

Share this post


Link to post
Share on other sites

Thank you for that. There is so much to go wrong on these cars ,it's knowing where to start , so any information helps.  

Thats why we love them    Thanks again

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...