Jump to content

Restricted performance but no fault codes Diesel


Jwlowther
 Share

Recommended Posts

Hi all, despite having my third S type I am a new member here hoping somebody can help with this annoying niggle. As there are no fault codes I can only think it as non-electrical... When I run the car with a light right foot it runs fine but as soon as I add power it comes up restricted performance... it’s the same when starting the car if I go through the procedure of turning the ignition key on and off two or three times as if priming the filter after change it runs well for a fair amount of time ...I seem to remember the Ford C Max did this when it needed a fuel filter change... So I change the filter and even though it’s better it’s still doing it. I have been told by a diesel fitter who owns the range Rover with the same engine that sometimes the pick up pipe in the tank can get blocked ...It just seems like there is a fuel restriction somewhere...does anybody have any ideas? any help would be greatly appreciated, Regards Jon

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership