Jump to content


S type engine coolant leak


Ian Hardwick
 Share

Recommended Posts

Hi I’ve bought an S type last week, very good condition great service history. But it has developed an engine coolant leak. The warning light came on a few days  ago I’ve topped it up then it seemed fine for a couple of days then the light has come back on. It’s lost fluid but I can’t find any sign of leak. It’s definitely losing fluid while not running. And there is no white residue in the oil. ANy help?

Link to comment
Share on other sites

1 hour ago, Ian Hardwick said:

Hi I’ve bought an S type last week, very good condition great service history. But it has developed an engine coolant leak. The warning light came on a few days  ago I’ve topped it up then it seemed fine for a couple of days then the light has come back on. It’s lost fluid but I can’t find any sign of leak. It’s definitely losing fluid while not running. And there is no white residue in the oil. ANy help?

update, ive now got a visible leak from underneath the car drupping from a pipe located next to the front drivers wheel, could it be a pipe thats perished or could this be the rad?

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
On 6/28/2021 at 1:41 PM, Mike Kinna said:

Probably plastic header tank. Common problem.

+ 1.

the plastic connector of the small hose was broken. I payed € 180,- for a new tank. Put in by myselves.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership