Recommended Posts

I'm so glad to join.  I have recently purchased my first Jaguar ( a 2003 X400 ) and although it's not the highest spec it's a lovely ride.

I bought it from a dealer who took it as a trade-in and according to my mechanic who MOT'd the vehicle, I got a really good deal.  So just like the trainspotter who fell in front of the Flying Scotsman - I was chuffed to bits. (sorry if you've heard that before :w00t:).  The downside is that the heater doesn't work, nor the heated rear screen or the the a/c.  In fact nothing on the panel except the blower.  So once it warms up a bit (it's currently sub-zero in Scotland) I will start checking the fuses and relays.  Anyway, if I can't work it out, I'll come back and ask for some help.

Cheers.

Share this post


Link to post
Share on other sites

Welcome to the club, Steve.

Good luck with your work on the hearer.  The temperature is zero in the usually mild Midlands so I do understand what it is like in the North.

I think you will enjoy your Jaguar, though.

Regards,

Peter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...