chrisM8168

Alarm Sounding whilst driving

Recommended Posts

I am a new owner ( and hence a also a new member ) having bought a a very low mileage 2007 X Type today from an auction. Was starting to think I had the bargain. However whilst driving this evening, i had the cruise control on at 40 mph and started to go round a "slow" corner when the horn started sounding and the cruise control disengaged. The horn then carried on sounding intermittently for approx 1/2 mile until I got home and switched off the engine ?

Has anyone an idea of what might be happening ?

 

Many Thx in anticipation  

Share this post


Link to post
Share on other sites

Hi Chris, and welcome to the club.

My first thought would be low battery: You bought the car yesterday, and it may well have stood around a bit, and had some short journeys before then. These cars throw up random electrical issues if the battery is less than fully charged.

I would get a CTEK battery conditioner (or similar) and charge it for at least 24 hours, to see if that helps.

I trust that you will go on to enjoy both the car and the club!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...