Jump to content


glow plug relay location X260 (XF)


chippy17
 Share

Recommended Posts

HI All,

Still having issues with the glow plugs on my 2016 XF 2.0D.

Have removed all 4 of the glow plugs and tested them on a 12v supply all are working, but the engine still miss fires for a few seconds when really cold.

I suspect that the glow plug relay might be suspect, only problem is i cant fid it!! can anyone help with the location?

thanks

John.

Link to comment
Share on other sites

  • 2 years later...
On 12/5/2019 at 8:42 PM, chippy17 said:

Hi All

Have found glow plug relay now!

Sited O/S chasis rail behind radiator.

oblong unit about 3 inches long, aluminium heat sink with two large conectors.

Did you sort your problem?

Link to comment
Share on other sites

  • 10 months later...
  • 1 month later...

HI AussieScot, did you locate the relay? My x260 also 2016 3.0D started taking a bit longer to start last couple of weeks. Have received and cleared the error code 'P052F' (Glow plug control module - voltage malfunction) a couple of times. If any1 can spare me some time with the location and part number that would be appreciated!

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership