Jump to content

Amplifier draining car's battery


KevinFX22
 Share

Recommended Posts

I'm not sure if anyone else has had this problem, but my 2008 X type estate's battery began to give me problems that seemed to be down to its age. I replaced it and the new battery discharged over a period of 48 hours down to 2 volts. As I was hunting for what had to be something draining the power with the ignition off I heard a very faint buzzing noise coming from the area of the sat nav and multi changer in the rear wing that I had never heard before.  To cut a long story short, I've discovered that the amplifier is the culprit. When the ignition is turned off the amplifier still draws power. I've removed it and repositioned it so that I can unplug it when the car is not being used. We will see what happens, but when it is unplugged there seems to be no power drain.

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership