Jump to content


Need a few answers


Phil58
 Share

Recommended Posts

hi all. Just test drove a 52 2.5 stype, after about a mile the vsc light came on also something like no disc something came up as well. After turning engine of then restarted both were gone but I am sure they would be back, is this a big fix? Also on mot checker it's had a fail on hand brake then passed that was on the one before last mot. Last mot gave advosory on hand brake saying right on the limit needs adjusting or repairing. Is this another worry or big repair job. Any advice Asap please. Phil

Link to comment
Share on other sites


Is the car you took for a test drive with a dealer? then if so raise the questions and if wish to proceed with a purchase ensure its on the condition that any problems you have noted are corrected and if possible get it in writing.

Link to comment
Share on other sites

Your not having much luck are you???

i wasn't looking for a jag, wanted a P38 Range Rover but the wife stumbled upon a nice looking '99 3.0 petrol and after a test drive we bought it.

Then, I decided I wanted a newer one, found one in Liverpool, test drove it and bought it.

Maybe I was just lucky.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership