Jump to content


No air coming out of top vents


GregMiller
 Share

Recommended Posts

2007 S-Type no air coming out of the top centre air vents when these vents are selected vis the mode button, air blows out the foot well vents no matter what mode is selected. Has anyone had a similiar problem.

Link to comment
Share on other sites


Sounds like blend motors are either inop or stuck.

With ignition on and fan low switch between up and down and face and listen, you should hear motors changing flaps behind dash.

If they're gone it's not a bad job, just fiddly.

Link to comment
Share on other sites

Thanks for the reply Andy.

Switched between different airflow posistions but don't hear no sound of flaps or motors moving. How do I get to these blend motors? Could it perhaps be a fuse that is blown?

Link to comment
Share on other sites

  • 7 years later...
On 5/24/2015 at 12:40 PM, Mr Lawrence said:

Think you take the glove box out and there up behind the dash.

Don't know about the fuse but worth a check

Also, have you ever heard a gurgling noise on switch off??

I just came across this post. I have the same issue. I used to hear a gurgling noice for awhile before the front center and side vents stopped working. 
I see the stopper motors and the one behind the center console (difficult to get to) seems the only one that’s not moving. 
I have a 2008 s-type

Link to comment
Share on other sites

How can I take the white clips that hold the rods to the stepper motor and the lever?

thank you in advance for your help

Link to comment
Share on other sites

There are 5 blend motors, remove them and disassemble. Clean and regrease the carbon tracks. Download the workshop manual for a guide. A gurgling sound on startup is low refrigerant for Aircon. Halfords sell a R134a refill kit but fill in stages, it's easy to go over pressure.

Link to comment
Share on other sites

8 hours ago, JustBadly said:

There are 5 blend motors, remove them and disassemble. Clean and regrease the carbon tracks. Download the workshop manual for a guide. A gurgling sound on startup is low refrigerant for Aircon. Halfords sell a R134a refill kit but fill in stages, it's easy to go over pressure.

Thank you Justin, the center blend motor has stopped working. Now I have another issue. 

When the car is idling, it does not produce cold air but as soon as I start driving (rpm goes up) I get cold air.

 

Link to comment
Share on other sites

On 6/23/2022 at 5:28 PM, Angelo said:

When the car is idling, it does not produce cold air but as soon as I start driving (rpm goes up) I get cold air.

 

The CCM will cut the Aircon if the refrigerant pressure drops too low as well as too high. Call in to Halfords and buy the kit or visit an Aircon specialist.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership