Jump to content


Engine runs when key is out of ignition, constant ignition lights


Neild123
 Share

Recommended Posts

Hi all

On a recent trip to wembley my x type developed an odd problem

I turned it off at services and it kept on going!! I had to stall it and remove the battery when leaving it as ignition lights are constant any help would be very much appreciated

Link to comment
Share on other sites

Hi Neil,

 

I have heard of this quite a few years ago in an old car.

 

I am not an engineer, but `I think the cure was a de-coke.

 

I would try giving the car a terraclean service which will clean out the fuel system.

 

Regards,

 

Peter.

Link to comment
Share on other sites

Well more bizarre than frightening really guys the car hasn't reached 70000 yet and is garaged for pretty much of its life. I know what you mean by a decoke but think it's electrical to be honest it seems that it is receiving a false signal

Link to comment
Share on other sites

Hi Neil, had this problem with s type 2000, got home switched off ,locked up and engine still running, not technical person from memory garage had to replace part at rear of ignition switch which had burned out, hope this makes sense.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership