Jump to content

Central Locking issues


Recommended Posts

Hi All.

I seem to have developed a central locking issue. I can lock/unlock ALL the doors and boot using the key in the drivers door as I used to be able to with the fob, but now I can only lock/unlock the passenger doors and boot with the fob and have to use the key to unlock/lock the drivers door. is this a common problem or is there some special kind of sequence to activate unlocking the drivers door with the fob. I recently pressed and held the lock and unlock buttons for 3 seconds so that all doors unlock with just one press of the unlock button but have done this again so you require two presses of the unlock button to open the passenger doors and It makes no deference which mod the fob is in I still have to use the key for the drivers door.

 

Is there another sequence that enables the fob to unlock ALL doors and boot.

 

Any ideas please  :unsure:

Link to post
Share on other sites

Hi Michail

I had a very simular problem as you about 4 months ago and fitter who works on my car cured

it with  no charge??    This is what he done====

 

Key in ignition and on

 

drop window drivers door.

 

stand out-side the car with the door closed ignition still on

 

put hand into car and work the small locking lever thats just above the inside door handle

in and out a few times and if its really stiff squirt some WD40 into the handle and also the lock .??

 

work it again untill its free .??

 

Turn ignition off so it resets --window up and retry the locks with the Fob.??

 

He said if this dos'nt work its the door lock at fault .??

 

I hope this Helps.

 

Frank

  • Like 1
Link to post
Share on other sites

Well I gave the latch on the door and the lock a good squert of WD40 but still no joy with locking/unlocking with the fob. When we get a nice day I will investigate further  and remove the door trim to check the internal mechanisim.

Link to post
Share on other sites
  • 5 years later...

hi guys just developed a central locking problem on my jaguar x type 2.2 2008 it will only open the drivers door lock with the remote and key but the rest of the doors are deadlocked cant even open them from the inside any idea's guys.

Link to post
Share on other sites

Sorry guys, I can't help with these specific issues.  However, I have occasional issues that my entire central locking system stops responding to the both fobs, but everything works with the key..  After a few hours/days/weeks it starts working again and can be fine for many months.  Can anyone help?  In the meantime, when it happens again. I'll try some of the above procedures.

Link to post
Share on other sites

Hi all,

Sorry to thread hijack but I also have a similar issue.

I've recently had to change X-Type owing to my old one I had had for over 10 years having a sudden attack of rot between MOT's that was not cost-effective to repair.

I've now got a 2005 Sovereign, but there's an issue with the central locking...

If you use the remote, the passenger front door does not lock or unlock at all. Equally, if you use the internal lock switch on the drivers door, the other 3 doors all respond as required but the front passenger one is non-responsive and has to be moved manually from inside.

HOWEVER, if you use the front passenger lock when the car is locked, it opens all 4x doors centrally. And, equally, if you use the front passenger lock to lock the car, they all lock as required.  It's as if it is detached from the main locking system but has one of it's own!

Is this an easy, obvious fix or is something slightly more sinister going on somewhere?

Just really annoying as I have to lock that door internally before I can get out and lock the rest of him and equally if a passenger is getting in I have to lean over and unlock it for them.  I know we always used to do this years ago, but.... 🙂

Thanks in advance.

TMW

Link to post
Share on other sites

Definitely not the remote in my case - that's all good and working fine.  The remote just sends a signal to trigger the locking to go (I think) and that works fine, as do the lights and boot release buttons on the remote. 

TMW 

 

Link to post
Share on other sites
On 12/1/2020 at 8:04 PM, tmwsccsh said:

Definitely not the remote in my case - that's all good and working fine.  The remote just sends a signal to trigger the locking to go (I think) and that works fine, as do the lights and boot release buttons on the remote. 

TMW 

 

Yes, I thought mine was all fine and dandy. Had the same issues as yourself - £15 isn't a huge amount to pay out to fix something on a Jag is it? When I took the key apart, there appeared to be a chemical residue on the PCB. This may have had something to do with it?

Link to post
Share on other sites
5 minutes ago, FazerScotty said:

Yes, I thought mine was all fine and dandy. Had the same issues as yourself - £15 isn't a huge amount to pay out to fix something on a Jag is it? When I took the key apart, there appeared to be a chemical residue on the PCB. This may have had something to do with it?

Hi,

Thanks for the response.

I should have added, the Driveaway door locking doesn't work on the passenger door either - if it's open, it just stays unlocked when the others all lock so I think that would eliminate the remote as the cause.

Regards

TMW

Link to post
Share on other sites
2 hours ago, tmwsccsh said:

Hi,

Thanks for the response.

I should have added, the Driveaway door locking doesn't work on the passenger door either - if it's open, it just stays unlocked when the others all lock so I think that would eliminate the remote as the cause.

Regards

TMW

Have you had a chance to check the loom in the hinge area of the passenger door?

Link to post
Share on other sites
  • 3 months later...
On 11/28/2020 at 8:58 AM, bob1969 said:

hi guys just developed a central locking problem on my jaguar x type 2.2 2008 it will only open the drivers door lock with the remote and key but the rest of the doors are deadlocked cant even open them from the inside any idea's guys.

Hi bob did you manage to find the problem as i have the same issue 

Link to post
Share on other sites
On 3/9/2021 at 3:53 PM, freddy777 said:

Hi bob did you manage to find the problem as i have the same issue 

Hi bob i had the same problem and it was fuse 22 behind the glove box 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...



Forums


News


Membership