Recommended Posts

Having big problems with my 3,2 XJ8... I stupidly let the battery go completely flat.. After replacing the battery I am getting a few fault messages, including ABS and stability control fault.. But the most serious is GEARBOX FAULT and the car goes into limp home mode, If I turn off the engine everything is back to normal for about 30 seconds, then back to limp home and gearbox fault message.. The Car was running perfectly before the battery change... Please Help Me, !!!!! 

Share this post


Link to post
Share on other sites

HI

Have you fitted a new battery,

usually a new battery cure's all the faults, is it fully charged, put it on a trickle charge over night, could of been sat in a shop for months

cheers

Joe

 

 

Share this post


Link to post
Share on other sites

Cheers Joe.. apparently the alternator is pushing out 19 vaults, so I will have to replace that as well because its obviously overcharging everything and frying the battery...  So thats my next step.. Thanks.. Greg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...