rht54

Gearbox fault light ?

Recommended Posts

Anyone had this problem before ? , The car has been reat since I bought on Christmas eve. Today got in it , pulled off the drive and got to the first junction , pulled out and the engine management came on and a waring "Gearbox Fault" flashed up under the speedo....stopped when I could ,switched off ,then tried it again ,fine no warning lights , carried on for 6 miles then it happened again , same as before stopped ,switched off ,re-started fine .Drove back from shopping approx 6 milles stopped at junction waiting to turn right ,pull off and agin the lights came on . It seems to get stuck in gear when the lights came on . Re-statrt it ,lights out and the box changes loverly again , Any ideas guys ????
Its a 2008 X-type 2.2d Soverign Auto ....

Share this post


Link to post
Share on other sites

Hi Jim ...

Thanks for your reply , my car has done 50,800 miles and with regard to the gearbox being serviced I don`t know mate ...

I had a garage look at the fault codes today and there were quite a few , maybe still on there the car was first used , anyway there were two that could be the problem , one a tirbo error and the other a gearbox fault , reading other posts these could be related ...

I drove the car back approx 6 miles and the light came up and the car went into limp mode , its odd as its always arounf 6/7 miles after resetting it comes back on again .

Tomorrow I`m going to drive to teh garage and see exactly what the faults are now in the ECU...

Cheers

Ray

Share this post


Link to post
Share on other sites

Hi Ray,

Had exactly the same problem on my 08 estate, 90,000miles took it to independent garage. They removed the turbo and showed me a small amount of carbon within.

Replaced turbo, now fine and now done 95,000 ok

Hope this helps

Cheers

Rod

Share this post


Link to post
Share on other sites

Hi Rod ....

Could the garage not remove the carbon and give it a clean instead of fitting a new turbo mate ?

My Jag has only done 50,800 miles ...

 

Ray ...

Share this post


Link to post
Share on other sites

Hi Ray,

As i only bought the car a few weeks before this problem the garage paid for it hoping to claim it back from the warranty outfit but they declined to cough up so the garage carried the can.

Cheers

Rod

Share this post


Link to post
Share on other sites

Ah right , still you got it sorted and hopefully it will give you trouble free motoring for a while ....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...