RugbyGuy

Rear windows & folding mirrors not working

Recommended Posts

Well I'm now the proud owner of an XJ.  62 plate MY2013 portfolio in Red, lovely car and drives so much better then my old Citroen C6 (though that was a bit of a special car too).

Took a few friends for a drive and everything seems to be working except for 2 things.

The rear windows will not open at all.  Neither the front or rear buttons do anything, tried switching on and off the child lock and playing with first and second positions but nothing at all. no clicks or sounds to suggest they are trying to work.  I can't pick out a particular fuse for the windows, but the ones labeled rear modules visually seem to be ok.  If I hold down the unlock button, which is supposed to lower all windows, only the front ones open.

2nd problem is the mirrors don't fold when I lock the car.  They do fold if I hold down the 2 buttons together, so they are definitely there, but I would like them to fold when I lock the car.  Manual says this is a dealer option, so it may be that I go back to jaguar to fix but just want to make sure.

Has anyone got any ideas of what to try for these.  I'll go back to the garage but wanted to make sure I wasn't missing anything obvious for these issues first.

Thanks

Share this post


Link to post
Share on other sites

Well car is off to the garage today.   It's getting picked up and dropped off, much better service than I got from Citroen.

i have noticed some rust round the sunroof so I'll see if that's covered under warranty too, I hope it is.

Share this post


Link to post
Share on other sites

Hi John, and welcome to the club.

When I bought my S Type from a main dealer,  I took it back after 2 months with a list a niggles.  It had been owned by the main dealer but had sat in a garage for three months.  They fixed all the niggles and almost three years later I have never had a problem that needed the attention of a  mechanic.

The should fix the rust issue.  I did think, though, that the XJ was an all aluminium build, so rust should not exist.

Let us know what they say.

Regards,

Peter. 

 

Share this post


Link to post
Share on other sites

Windows and mirror got fixed with a software update.

Theyve adjusted the sunroof as it was clunking when opening, and lubricated the runner.  But they haven't sorted the rust out, not sure whether to pursue it though.

they did give me a jar of sweets too :-D

 

Share this post


Link to post
Share on other sites
20 hours ago, RugbyGuy said:

Well car is off to the garage today.   It's getting picked up and dropped off, much better service than I got from Citroen.

i have noticed some rust round the sunroof so I'll see if that's covered under warranty too, I hope it is.

Corrosion/ rust of the sunroof frame is a known problem affecting xj cars up to 13my . Dealers and Jaguar are aware! Of the problem due using poor quality parts. They just hope no one looks around the frame when the roofs open and don't spot the problem until there 3 year paint warranty expires (Its 6 years for STRUCTURAL corrosion, But the crafty so & so's class the frame as none structural) Get back to your dealer and DEMAND that either a new frame or complete sunroof is supplied FOC under warranty. Don't take any bull:shit: from service reception! Repainting the frame you have fitted now won't cure the problem as what you see on top will be x2 times worse under! If your dealer doesn't want to know? Make a BIG issue of the problem with Jaguar HQ CS as your be timed out soon on making a claim.

Share this post


Link to post
Share on other sites
On 3/29/2016 at 1:04 PM, RugbyGuy said:

Well I'm now the proud owner of an XJ.  62 plate MY2013 portfolio in Red, lovely car and drives so much better then my old Citroen C6 (though that was a bit of a special car too).

Took a few friends for a drive and everything seems to be working except for 2 things.

The rear windows will not open at all.  Neither the front or rear buttons do anything, tried switching on and off the child lock and playing with first and second positions but nothing at all. no clicks or sounds to suggest they are trying to work.  I can't pick out a particular fuse for the windows, but the ones labeled rear modules visually seem to be ok.  If I hold down the unlock button, which is supposed to lower all windows, only the front ones open.

2nd problem is the mirrors don't fold when I lock the car.  They do fold if I hold down the 2 buttons together, so they are definitely there, but I would like them to fold when I lock the car.  Manual says this is a dealer option, so it may be that I go back to jaguar to fix but just want to make sure.

Has anyone got any ideas of what to try for these.  I'll go back to the garage but wanted to make sure I wasn't missing anything obvious for these issues first.

Thanks

Disconnect the battery earth for 10 minutes and that should return the car to default settings. Windows should open and the mirrors should auto fold on locking..I think you have to input in settings if you require the N/S/M to auto dip to the kerb in reverse.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...