Jump to content

Done it again


Gordy
 Share

Recommended Posts

So coming back home a 90 mile trip stopped at Tesco to do a bit of shopping in there 10 mins went to start it again and nothing all dash light ok everything work but would not turn over left it 20 mines and all fine again yesterday after the first time did a few short trips and all was ok its as if on a long journey something is getting hot and breaking down any idea's please

Link to comment
Share on other sites

Hi Gordon, 

I take it that your car is a diesel, as a member had the same problem with his x type 2.0 diesel.   It refused to start when hot, and was told by a main dealer it was the injectors and glow plugs, which would cost him £1200 to replace.  He had the terraclean service done and it was cured!

Possibly a can of "Diesel Magic" would help as a starter.

Regards,

Peter. 

Link to comment
Share on other sites

8 minutes ago, Old Peter said:

Hi Gordon, 

I take it that your car is a diesel, as a member had the same problem with his x type 2.0 diesel.   It refused to start when hot, and was told by a main dealer it was the injectors and glow plugs, which would cost him £1200 to replace.  He had the terraclean service done and it was cured!

Possibly a can of "Diesel Magic" would help as a starter.

Regards,

Peter. 

Thanks Peter will try that

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership