Recommended Posts

Hello I am new to Jag ownership. I currently have a 2006 S type 3 litre petrol. I did some research before the purchase drove a few, then bought one. I've had the usual problems.

1. Code PO420 cat efficiency below threshold and PO303 and PO304 misfire 3 and 4 

2. Misfire on both sides, so replaced plugs and coils, removed valve covers (as oil in plug holes) replaced with seals, turned of management light. Hoping this would also cure the cat issue. The car has been running fine since but not for long.

3. As now the car has developed a loud induction noise when it is throttled hard, loss of power  and the gear box cant decide it it wants to change down management light came on again code PO420 bank 1. So removed all air intake parts including manifold and put it back together checking for cracks or holes turned off light. But this problem has not gone away.

Any ideas? (Blocked cat?) (Fuelling or timing?) Or is it so simple that I'm missing it?

Thanks in advance for your help regards Dave

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...