Marcos

Electronic brake problem

Recommended Posts

My 2007 s type has a msg saying cannot apply electronic brake and a flashing abs light,it was fine when I used it yesterday.  HELP.

Share this post


Link to post
Share on other sites

Hi Marcus and welcome to the club.

Make sure you have the radio code to hand and the car key in your pocket.

Disconnect the battery and after 10 seconds or so reconnect.

The alarm will go off, so shut it off wing the key.

You will also have to press down the bake pedal and with off the handbrake.

It should now work OK.

You will have to reset your radio, windows and sounds.

It is useful to keep the battery charged.

Let me know if this works with your car.  It should.

Regards,

Peter.

Share this post


Link to post
Share on other sites

Thanks Peter I will try that. It started when we had that cold spell a few months back. I started the car and when I put it in reverse it didn't want to move,I let it warm up and tried again,it moved then the msg no electronic brake. I will let you know Cheers

Share this post


Link to post
Share on other sites

Hi Peter one quick question. Should the engine be running when I press the brake on reconnection of battery.

Share this post


Link to post
Share on other sites

Not necessary, Marcos. but I usually start the engine when it has happened to me.

Peter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...