ricksatluz

X type temperature gauge fluctuations

Recommended Posts

My temperature gauge on my 2lt diesal is misbehaving!! I noticed it not recording normal temperature staying in the cold section,I determined that it was the thermostat! My garage replaced it while having a service, when I drove it away it was showing normal temperature, however after a few miles it started dropping? I was driving into London and in the usual traffic it held normal temperature, but on the journey home when on open roads and motorway the temperature gauge went to cold? Mystified is the word! As it help temperature in traffic one could assume the stat is working so why does it drop when on motorways 

Share this post


Link to post
Share on other sites

I had the same problem with mine (2008 2.2d 6sp manual), I ended up replacing the oil coolant thermostat and everything worked fine. 

There is a well read topic on this forum on the very same scenario. 

HTH

Share this post


Link to post
Share on other sites

Thanks for the reply. You are correct I changed mine and the problem is solved. Also changed the main thermostat and head temperature sensor and water pump while I was at it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...