Jump to content

Lost gears


Arthur59
 Share

Recommended Posts

Driving my 2013 XF s-portfolio, which I have owned for 5 weeks, i had a message saying that the battery was not charging. I stopped the car and re-started it, all ok.

Shortly after 20 miles the problem came back.

What's the problem??

Link to comment
Share on other sites

Welcome to the club, Arthur.

The first question is "How old is the battery?"

Batteries normally last 5 years or so, so a guess is telling me that your battery needs replacing.  If it has been replaced I would check it to see if it is the correct battery for the car.

Let us know how you get on.

Regards,

Peter.

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership