Jump to content

Front indicator not working Xenon XF 2,2D 2013 Face-lift


CliffX
 Share

Recommended Posts

Hi. I am rebuilding my 2013 facelift XF modal after a front RH shunt. The headlamp was shattered, I have procured a used lamp assembly but find the indicator LED is not indicating. The seller assures me that the lamp was fully working when dispatched. All lights are working and all indicator lights work except the front RH headlamp indicator LEDs, the door mirror indicator light also works.
I have recorded the sound produced at the dash with engine off, ignition on. The sound is asymmetrical but rhythmic sounding like a code. 
Can anyone help locate the source of the fault?

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership