Jump to content


engine management light on


redjag
 Share

Recommended Posts

  • 2 weeks later...

how many miles has the car done, has it been maintained by Jaguar or an indie jag specialist?

A car of this age it could be a number of things the fuel filter (service part) could be the problem and would need to be replaced.

other issues are IMT valve gaskets worn (2x £6 replacements and 5 mins to replace)

spark plugs need replacment

MAF sensor replacement

breather for the Oil (over the rocker covers) could be leaking (common problem with the older smooth type) £20 replace as DIY

one of the sensors running out of tollerence and probs either needing a clean or re-program to bring into tollerance.

my guess would be Oil breather, IMT rings and fuel filter the latter being the hardest to do as a DIY job

without the Error code there is very little in way of help unless ure in the Aberdeenshire area then I could plug into ODB with either reader or IDS system.

Link to comment
Share on other sites

how many miles has the car done, has it been maintained by jaguar or an indie jag specialist?

A car of this age it could be a number of things the fuel filter (service part) could be the problem and would need to be replaced.

other issues are IMT valve gaskets worn (2x £6 replacements and 5 mins to replace)

Spark plugs need replacment

MAF sensor replacement

breather for the oil (over the rocker covers) could be leaking (common problem with the older smooth type) £20 replace as DIY

one of the sensors running out of tollerence and probs either needing a clean or re-program to bring into tollerance.

my guess would be oil breather, IMT rings and fuel filter the latter being the hardest to do as a DIY job

without the Error code there is very little in way of help unless ure in the Aberdeenshire area then I could plug into ODB with either reader or IDS system.

Link to comment
Share on other sites

  • 5 years later...

Hi, I'm new to the forum but I have this problem on my xtype '04 reg 2.1 V6. I have replaced the mass air flow sensor to no avail. I get an awful shuddering at 3k rpm. Any help would be greatly appreciated 

 

thanks 

image.jpeg

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership