Jump to content


X type radiator fan over running.


DUNKS
 Share

Recommended Posts

H I have a problem with the fan running when engine is switched off.

I have read yards and yards about this problem and am still in the dark as to what might cause it and am open to suggestions PLEASE!

X type 2009 2.2 diesel sovereign. Car works as it should except for this newly developed fault.

Short or long run makes no difference but fan runs at full speed when engine is switched off. "It's not running before this". I have let motor idle before switching off but makes no difference. I have not tested how long the fan will run for but certainly couple of mins and still belting away.

re start engine and switch off immediately and fan stops.

No loss of cooling water and engine temp is ok.

Any suggestions please.

 

Link to comment
Share on other sites


Two variable speed electric cooling fans are housed in the cooling fan shroud for the cooling of the radiator. The speed of the electric cooling fans are adjusted by the cooling fan motor control module, which is controlled by the engine control module (ECM).
The ECM determines the cooling fan speed by receiving inputs from the engine coolant temperature (ECT) sensor and the dual automatic temperature control module (DATC). The ECM sends a variable pulse width modulated (PWM) signal to the fan motor control module to operate the cooling fans at the required speed. The cooling fans are operated at slow speed when the engine coolant temperature is at 95°C (203°F) and are operated at full speed when the engine coolant temperature is at 105°C (221°F). A coolant temperature between these temperatures will cause the cooling fans to be operated at a speed which is proportional to the engine coolant temperature.
When the engine is running with the ECT above 100°C (212°F), if the ignition switch is turned to the OFF position the cooling fans will continue to operate for a time which is determined by the ECM.
If the PWM signal from the ECM to the cooling fan control module is between 7% and 95% the cooling fan control module will operate the cooling fans at the required speed. If the PWM signal from the ECM to the cooling fan control module is below 3% and above 95% the cooling fan control module will operate the cooling fans at maximum speed. If the PWM signal from the ECM to the cooling fan control module is between 3% and 7% the cooling fans will not be operated.  hope this helps?

 

Link to comment
Share on other sites

HI

looking at the info below, it could be a faulty cylinder head temp sensor or cooling fan controller

looks like its controlled from the engine ecu, can't see this failing, but temp sensor is possible or fan controller

also here a manual might help http://www.the-colliers.net/docs/public/guides & manuals/Jaguar Workshop Manual X-Type 2001-2009.pdf

hope this helps

cheers

joe

ScreenShot109.jpg

ScreenShot108.jpg

 

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Things got worse before they got better.

Apart from the cooling fan running on the engine management light came on, the dash temp gauge went potty and decided to work only when it felt like it. The turbo cut out when the engine got warm.

TOOK IT IN TODAY TO A JAG SPECIALIST AND IT'S THE CYLINDER HEAD TEMP GAUGE THAT'S AT FAULT.

 

SORTED.

Link to comment
Share on other sites

Things got worse before they got better.

Apart from the cooling fan running on the engine management light came on, the dash temp gauge went potty and decided to work only when it felt like it. The turbo cut out when the engine got warm.

TOOK IT IN TODAY TO A JAG SPECIALIST AND IT'S THE CYLINDER HEAD TEMP GAUGE THAT'S AT FAULT.

 

SORTED.

Link to comment
Share on other sites

  • 2 years later...
  • 1 year later...

I have an almost similar problem , the fans run non stop even with car cold or switched off , i have to disconnect the battery for them to stop and not drain the battery , they will run until the battery dies.

Link to comment
Share on other sites

  • 7 months later...

I have a similar problem with the cooling fan running for hours after engine is switched off, it killed the battery. 

The second problem is it emits fumes for the first few miles until the error mesaage appears "DPF full see owners handbook" anyone with the same problem? 

Link to comment
Share on other sites

  • 7 months later...

Hello,

I have a similar problem, when I give contact to the car, the fans turn on and work all the time until I turn off the car. The thermostat, temperature sensor and fan module have been changed. It's none of those things! They stop working as soon as the engine is on optimal temperature, but as soon as the car cools down and turn on again, they start working….
If anyone has any advice? Tnx

(Jaguar x-type 2007)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership