Recommended Posts

Good afternoon.

I really hope someone can help me.

I have a 2004 XK8 4.2 Convertible.

My "J" gate manual mode was not working and sport button was not working.

I replaced the linear switch and all was well for about 30 mins.

After that the "D" started to flash, the manual mode wouldn't work and the sport button would not illuminate.

After extensive research I found the body control module supplies the linear switch with a second feed.

It should supply it with 10v but it was only supplying it with 5 volts.

The part is now obsolete so I put in a used one , programmed it and now it supplies it with 6.5 volts still not the 10 volts required.

I am now at a loss and don't know what to look at next.

Any suggestions would be much appreciated.

Thanks you. 

Edited by Marc01
spelling error

Share this post


Link to post
Share on other sites

Hi

hard to say this one, looks like you know what your doing

but I'd go over all the connections, make sure theres no corrosion on the connectors

other thing I would check is make sure theres no breaks in the wiring between the j-gate and the gearbox, as thats where all the movement is

you have had it working once, try wriggling the loom to the gearbox, might be just a break

the 10v from the body module sounds strange, would of thought it would be 12v

I take it its the 6 speed zf 6HP26

cheers

Joe

 

Share this post


Link to post
Share on other sites

Joe,

Thank you for your reply.

I have checked and tested all the relevant wiring.

I am now confused.

Thanks.

Share this post


Link to post
Share on other sites

How old is your battery.   A battery on its way out can give you all sorts of weird and confusing symptoms.  Yes I know you have probably sorted it by now but did you fix it?

Share this post


Link to post
Share on other sites

hi

frank you do know this post is over 2 years old

cheers

 

Share this post


Link to post
Share on other sites

Sure do.   Have a read    

Just trying to help others that may currently and in the future find a solution.   Nothing much sees to happen on this forum.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...