Jagnumpty

Coil pack or ... ?

Recommended Posts

The other day the EML light came on and the engine went into ultra limp mode. I wasn't far from my self styled Jag 'expert', so I popped in and he plugged in his OBD system. He reported that the trouble was the coil pack on cylinder 5 and reset the error code. That was enough to almost  get me the 2/3 mile home when it happened again.

Since my previous bluetooth OBD was acting up I bought a replacement and connected it to the 'Torque' app on my phone. This reported that Bank 1 was running lean and that there were other 'potential problems'.

Does that sound like a coil pack to anyone? I'm too used to real coils serving multiple cylinders rather than a mini one for each, so it's all Greek to me.

Share this post


Link to post
Share on other sites

chances are slim... i had torque reporting 2 coil pack issues. looked into it a little deeper and decided just to throw a set of plugs at her. fixed the issue.  i moved the suspect coilpacks to the front facing bank so that i only had to take the air filter off (rather than the whole manifold) if it was a coil pack at fault.

 

 

 

Share this post


Link to post
Share on other sites

Thanks. I'll give that a go. I'll pick up a set of Iridium plugs. Might even use my Halfords discount.

Share this post


Link to post
Share on other sites

New plugs arrived, but I'm considering getting a coil pack to see what happens when I swap one or more in/out.

However, after resetting the error codes several times, I have ascertained that things only go square shaped if the revs hit just under 3K. That's when the misfire hits and the EML goes on. If I keep the revs under that self imposed limit the car runs relatively sweetly.

The only problem otherwise is that the car doesn't feel  like a Jag. Nothing i can put my finger on, but ... y'know ... 🤥

Share this post


Link to post
Share on other sites

Hi I have 03 plate x type with misfire on 2,4 and 6 Coil pack at the moment,my mechanic said it's the wiring to the coil packs breaking down! Has anyone had this trouble?

Share this post


Link to post
Share on other sites

Now fixed,the front 3 spark plugs are now changed,also had idle valve taken off along with throttle body and had them cleaned as deposits build up! 3 back plugs to follow as more tricky to get to! Fault showing was wiring to bank 2,4 and 6 I personally think the lifetime plugs needed changing! As it's back to a luxury flying machine again.

Share this post


Link to post
Share on other sites

Back into limp more again help any advice gratefully received!

Share this post


Link to post
Share on other sites

I've decided that when the MOT comes due (and it passes), I'm flogging the Jaaag and putting my US built Dodge Ram Day Van camper conversion on the road as my daily driver and holiday/tow car. 6 seats and still room for a 1/4 size traction engine and mobility scooter while towing a 5 berth folding camper and running mostly on LPG.

What's not to love?

It pains me to say that the early 2000's Jaags ain't wot they uset ter be.

Wouldn't say no to an F-Pace, but who's got that kind of dosh?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...