H444YDN

Urgent Help Needed

Recommended Posts

Hi Guys,

I have 61 Plate XFs 3.0L V6.

All has been okay until today when I had the message "Battery Not Charging" message, Shortly after (2 Mins) all the faults popped up (ABS, ESP ect) the wipers turned on and the car went sluggish, the screen turned off along with the audio. Following this the instrument panel turned off aswell as the revs and speedo.

At this point the engine is still running and Im held up at a red light. once I tried to set off i moved a meter and the engine just cut out.

I managed to get it to a car to a Car park. We tried to get jump leads to get it going a the car was dead dead!! no power at all. with the jump leads the car turned twice and died again. but this resulted in the jump leads burning and melting (they were heavy duty.

I have replaced the battery and everything has come to life but once the new battery is connected there was some smoke coming from next to the fuse box in the engine compartment so I rushed to disconnect it!.

Does anyone have any Idea what the problem could be??

Thanks in advanced

Share this post


Link to post
Share on other sites
 

Hi Hayden,

I would suggest a significant short to earth is a possible fault. 

Beware of re-connecting your battery, the amount of current they can deliver is VERY high.

Unless you are a confident car electrician I would have your car taken to your local jaguar specialist.

Sorry it's not better news.

Mike

  • Like 1

Share this post


Link to post
Share on other sites

Sounds like this is a wash water pump problem. If you google this there are a number of posts.

Share this post


Link to post
Share on other sites

Ironically, me too! Around a week after yours, must be catching!

 

Share this post


Link to post
Share on other sites
13 minutes ago, Mike_eng said:

Ironically, me too! Around a week after yours, must be catching!

 

Same symptoms? Mine was smoking when I connected a new battery!! Was scary! Did it cost you much to get fixed?? 

Share this post


Link to post
Share on other sites

No smoke, and I managed to drive mine to the garage, it's only a few hundred yards away, I ended up paying 623 quid fitted which was painful enough

Share this post


Link to post
Share on other sites
19 minutes ago, Mike_eng said:

No smoke, and I managed to drive mine to the garage, it's only a few hundred yards away, I ended up paying 623 quid fitted which was painful enough

Ouch!!! I got a few quotes highest was £448! 

Do I bought the parts my self and got a local garage to fit them 

Alternator £162

Battery £96

fitting £80

recovery £30

Because the alternator pushed AC current back through the battery it fried it so I needed a new one! 

Share this post


Link to post
Share on other sites

I went for a Lucas alternator which was 330, they offered me one for 160 but I hadn't heard of it so I played it safe

Share this post


Link to post
Share on other sites
43 minutes ago, Mike_eng said:

I went for a Lucas alternator which was 330, they offered me one for 160 but I hadn't heard of it so I played it safe

Ah not bad then.  I got a 3 yr warranty on mine so didn’t think it was too bad. Just needed my car on the road ASAP 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...