Jump to content

Shuddering


ricksatluz
 Share

Recommended Posts

My 2004 x400 estate develops a violent shuddering when accelerating around 50 to 70+ 😉 it’s not wheel balance having just had them checked.my garage suggested bottom wishbones. Drop links and roll bar rubbers! £300+quid later still the same !!?. 

Suggestions? Anybody experienced the same and rectification!

Link to comment
Share on other sites

hi

its either going be a bent wheel, deformed tyre or if its a awd, drive shaft

have you tried swapping front wheels for rear and see if it shifts

other option is get under cars and try to lift and lower the drive shafts, if you have a sloppy one, that will be it

 

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership