Hammy0107

XF problem

Recommended Posts

Hi all, 

New Jag owner since July and loving it mostly despite a few issues. Today i heard a pop and instantly lost power and restricted performance light came on. I think I have found the issue but not got a clue what it is. Anyone tell me what this is and am i right in thinking it has split / popped. Can anybody tell me what this is and would this cause a complete loss of power. 

Thanks in advance. 

Share this post


Link to post
Share on other sites

hi

thats the intercooler radiator there known to fail, especially if they have been mapped

new intercooler will fix it

cheers

Joe

Share this post


Link to post
Share on other sites

Hi Had a very similar issue just last month, it turned out to be the turbo intercooler hose that had split.

Dealers diagnosed it and had a replacement in next day, I had my cat back just after lunch that day

Mine was done under warranty but if you don't have a warranty then I don't think it's too pricey at a good indy.

Although if you only got your cat in July you should still have a warranty to cover this.

Good luck,

Dom

Share this post


Link to post
Share on other sites

Hi Paul,

Just to add, one symptom I had, that if you have it would mean it's the same, is when you hit 2000rpm and the turbo kicks in I could hear a kind of whoosh/blowing sound, obviously the air being forced out of the split hose. You can't see the hose from the top, it's item 12 in the diagram below.

Name:  XF Intercooler.jpg Views: 54 Size:  66.0 KB

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...