Jump to content

Main beam comes on when using indicators


keithstype27
 Share

Recommended Posts

My 2007 S Type 2.7 has developed a fault whereby the main beam headlights come on when I use the indicators. This is day or night and makes no difference whether the dipped beam lights are on or off.

 

It started a year or two ago but began with just the occasional 'sticky' main beam - ie, they didn't go off if I used the 'flash' - so had to be flicked on and off with the main beam stalk to get them to go off again.

This problem has developed recently into a potentially dangerous problem in that whenever I use the indicator stalk, the main beam comes on and can't be switched off again by using the stalk - the stalk moves and clicks as usual but the main beam stays on. Other driver may misinterpret this as a sign to go ahead and turn in front of me or pull out in front of me or even a sign of anger on my part.

I have ordered a replacement stalk (used) and hope to change it in the next day or so and will keep this topic updated if the problem is solved.

Has anyone else had this problem and how did they manage to rectify it?

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership