Jump to content

Main beam and indicators not working


Jim003
 Share

Recommended Posts

Hi.Have posted this but in the new members section so do apologise. As you can guess then am no techno wizard.My drivers side wing mirror was hit.leaving the cover on the floor and the bulb inside the reflector lens.I put the cover back on,hoping my other indicators would still work.I turn them on and the worked for a very short time about 10 seconds.I replaced the bulb hoping that would rectify the problem.No joy.I have no indicators,and also no main beam.The direction arrows on the dash do not appear.The trip button on the arm is working.I have no manual at present. Could it be the fuse has blown if so,where is it located and which one would it be.My Jag is a 2008 diesel. Any help in this matter would be gratefully appreciated. Cheers!

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership