Jump to content

Recommended Posts

SOS!   Help

Just purchased a 2015 2 litre (mark 2 ) Jag XF.  Was learning how to use the Sat Nav system (basic) that seemed to be working just fine (after updating SD card) and exploring the system and the language has changed from English to well German or Polish or something I do not understand !!!  I have tried to restore to English that should be simple but despite trying everything I can't get it back. What is the magic button??

Did this with old Mazda and Tom Tom once and simple to change back.  I guess this is, if you know how!!

Any ideas please before I shoot myself!!

x

Link to post
Share on other sites

Hi Tim

Had the same problem when I updated my XJ sat nav it wouldn't recognise anywhere in the UK because it was set by default for Germany. I can't remember exactly how I did it but somewhere in Settings is a map of Europe and you just touch on UK and all is well. Sorry I can't be more precise but maybe someone with more idea will be along.

Cheers

Pete

Link to post
Share on other sites

Thanks Pete.  Luckily my daughter used to work for Landrover and the friendly colleagues tested the SD card for me and it was broken. This can happen now and again and even they could not update on their equipment . So under warranty a new SD card to come. Thankfully I am not going mad!

Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...



Forums


News


Membership