Jump to content

Annoying vibration any ideas


Recommended Posts

I have a xtype 2.0 diesel and recentley have fiund a vibration coming through front seats at 55-75 mph over or under this nothing. Had wheels balanced and checked. If go into neutral it stops. If cruising only on when accelerating seems worse as press accelerator. No noises or groans. Any ideas?

Link to post
Share on other sites

Do you feel it in the steering at all? All usual suspects for vibration like this would be steering components and possibly the bearing on the long driveshaft. Possibly even an engine mount

Link to post
Share on other sites

Thanks for that, vibration not bad on steering wheel mainly in front seats. If go into neutral vibration stops also if in cruise control, it is only on when accelerating between 55-70 if doing say 80mph no vibration. I forgot to say no problems with flywheel had that replaced 6000 miles ago. No leaks, no

noises. Is there any tests i can do for engine mounts or bearing on driveshaft as i took it to a garage and mechanic was unsure what it could be.

Link to post
Share on other sites

Only visual and physical movement checks really. An engine mount would usually be felt when taking up drive from stationary in either forward or reverse and would be heard as a light clunk. Driveshaft bearing is a case of removing the under tray and getting on your back under the car. If the shaft moves at all up or down in the bearing which is mounted to the engine (the driveshaft runs through it) then it's worn.

However, with that little extra info you supplied, it's possible that it is a misfire.

The 2.0D is renowned for injector faults and the speed you say it occurs at is common for the symptoms of a failing injector. Do you get any excess black smoke out the exhaust when you accellerate?

Link to post
Share on other sites
  • 2 weeks later...

I had the same issue on my car whilst test driving it. Extreme vibration under acceleration 50-70. The dealer got it checked out and it was the drive shaft bearing, he sorted it... I bought the car :-)

  • Like 1
Link to post
Share on other sites
  • 1 year later...

Hi,

 

I had the same with my 2.0 diesel x type 07 plate, vibration juddering through whole front of car when reaching speeds between 50 and 70 mph especially bad when accelerating. Replaced the o/s drive shaft . Cured it :)

Link to post
Share on other sites
  • 2 weeks later...

I had this same issue. After having the wheels checked for buckles and having them balanced. Theach alignment checked I then noticed I had play in both driveshaft's replaced them and it's back to super smooth driving!

Link to post
Share on other sites
  • 1 year later...

I have been quoted £580 for the drive shafts to be fixed. having spent £528 on caliper, discs and pads. £300 on tyres and balancing and tracking front and back.

It stings. Does £580 sound about right for the drive shafts to be replaced? (You all sound so nonchalant about the driveshafts that I'm questioning the price.....) 

Thanks in advance all, appreciate it's an old thread!

Link to post
Share on other sites

I just replaced my drivers side drive shaft myself. With a few basic tools, drive shaft was £35 on ebay (new) (amazing) Took me 2 hrs with the car on axle stands. All depends how handy you are.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...



Forums


News


Membership