Harv

Hot and cold air at the same time.

Recommended Posts

Well today I got a new fault to deal with, happy me!

 

With climate sitting at 20 deg, auto, and NOT set for dual temps, I had cool air coming out of the passenger vents and hot air from the drivers vents. Hot air continued even with the setting at low or below 17 deg.  For a short time the fault rectified itself when I was adjusting the controls from hot to cold but this was short lived and the fault returned.

 

I've done a bit of digging and it would appear to be either the dual climate control valve or the control unit or possibly both!!!!.

 

Has anyone else had this problem and if so how easy is it to replace the dccv. (I'm not frightened to have a go but I'm a bit of a novice.)

 

Also is it correct that if the valve is faulty and I don't replace it the Climate control module may be damaged?

 

Advice please

 

 

 

 

Share this post


Link to post
Share on other sites

Hi Harvey,

 

A bit strange,  but I would check again the dual set up via the climate control setup.  The cheap option is always worth trying.

 

Peter.

Share this post


Link to post
Share on other sites

Solved the problem. Stripped out the dual climate control valve which is deep down in the engine bay and discovered one of the electrical wires feeding it was broken, causing the heater valve for the drivers side to remain wide open. Re soldered the connection and everything now working as it should. For anyone else with a similar problem there is loads of info on the web. Took me 10 hours of work to trace and fix it though.

 

The main warning is this: If you have a problem like this DO NOT continue to use the car as the head unit heater controls in the dash board can be burnt out due to an amp surge, leading to a very expensive repair to the head unit. 

 

Hope this is of help to anyone with a similar problem

Share this post


Link to post
Share on other sites

I get hot air on both sides and cold air in the center, I changed the  valve and still have the problem. Whats next, is it the Jaguar S Type Climate Control Unit ?

Share this post


Link to post
Share on other sites

I have a 2006 s type diesel drivers side very hot passenger side works with aircon blows cold if set cold drivers side red hot. would you say this could be a broken wire rather than the valve fault

Share this post


Link to post
Share on other sites
13 hours ago, gr1 said:

I have a 2006 s type diesel drivers side very hot passenger side works with aircon blows cold if set cold drivers side red hot. would you say this could be a broken wire rather than the valve fault

Could be either. I took the valve out and tested it on a workbench with a 12v battery which confirmed that both solenoids were activating. This proved it was the wiring. 

Share this post


Link to post
Share on other sites
7 minutes ago, harv1963 said:

Could be either. I took the valve out and tested it on a workbench with a 12v battery which confirmed that both solenoids were activating. This proved it was the wiring. 

 

7 minutes ago, harv1963 said:

Could be either. I took the valve out and tested it on a workbench with a 12v battery which confirmed that both solenoids were activating. This proved it was the wiring. 

When taking out valve have some wine corks handy and insert them into hoses to stop fluid leaking out

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...