Jump to content


S Type 2.7 diesel


kenkar
 Share

Recommended Posts

My S type recently had,under warranty, a new DPF fitted and one new leaky injector which leaked diesel onto manifold. However when I am stationery I still get a bit of a smell. Anyone got an idea as to what it could be?

Link to comment
Share on other sites


Its more an exhaust smell. I have had a look and cant see or smell any diesel. The smell only comes in on drivers side vents. When running there is no apparent smell.

Link to comment
Share on other sites

  • 4 weeks later...

Thanks for all your replies guys. I am still getting exhaust fumes in the cabin whilst the car is in standing traffic, not all the time though, but when car is hot. We have checked exhaust pipes, all are ok. Had new DPF. This light does come on after a couple of days on short journeys but I reset it and its ok. Any more ideas?

Link to comment
Share on other sites

Yes I know and I try to! Its the fumes that are a problem.

 

Maybe your Webasto is working, even when it doesn't need to. Usually this only shows up in cold weather but if you still smell fumes in the car and your exhusts are OK it would be workth pulling the Webasto fuse for a few days and seeing if the fumes stop.

 

It's fuse 3 in the engine bay fuse box btw.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership