Jump to content


2001 S Type 3.0 V6 Sport. Auto transmission fault..


Disinferno30
 Share

Recommended Posts

Hi, I have a 2001 3.0L V6 S Type and I have a problem with the auto box... when I place the trans in to D is does nothing? works fine in reverse though? I have carried out a diagnostic check using my friends Snap On computer and it had these fault codes..

 

P0500 vehicle speed input failed.

p0720 Output speed sensor no signal.

p0731 Gear 1 incorrect ratio.

p0733 Gear 3 incorrect ratio.

 

The ABS warning light is showing on the das and also came up with DSC fault and transmission fault..

I would be very grateful if anyone has any suggestions?

Thanks in advance.

Link to comment
Share on other sites

Hi, I have only recently acquired the car from a friend of mines dad and as far as I am aware its been parked up for about 18 months, before it was parked up it had the transmission Oil and filter changed but still had issues, he also said that at the time it had a miss fire from one of the cylinders under the inlet manifold, the speedo didn't work and the abs light was on.. I've looked at a few posts on the internet that suggest these might be the issue not the transmission itself. but not sure which way to go with it really.. thanks for your reply and any help would be amazing!

Link to comment
Share on other sites

These cars need a tip top battery,so my first investigation would be to make sure the battery was perfect.It may seem daft but with a problem battery all sorts of codes and warning lights seem to show on the S-type.

Also if you can reset the fault codes.

Best Regards

Graham

Link to comment
Share on other sites

Hey, should be getting a new battery at the weekend so ill try that and delete the codes, I think ill sort out the misfire too and see what it comes up with then.. ill keep you updated if I get any results.

Thank you

Link to comment
Share on other sites

Hi,

if you will be removing the manifold it might be worth changing all the plugs their and testing the coils as i think this is a time consuming job and would be worth carrying out all the maintenance so that it does not need removing again.

If it was me then i would replace the battery first,reset the fault codes and take it from there.

Are you able to reset the fault codes with the code reader yoy have.

I am not completely sure but you may possibly need the Jaguar Software to do this.

But as always try the less expensive route first.......hope it works out for you.

Graham

Link to comment
Share on other sites

  • 3 weeks later...

Hi am new to this forum I have a 1999 s-type car runs mint it's a 3 liter auto j shift box car runs mint in normel drive but won't go in to second gear when u push it across to second it goes in to 3 and 4 ok but it is driving me mad eney help would be grateful to know what mite be causing this problem

  • Like 1
Link to comment
Share on other sites

Hi, the transmission filter and fluid was replaced just before the previous owner parked it up around 2 years ago.. I have access to various different scanners including Jaguar IDS, the fault code that it keeps coming up with is to do with the vehicle speed sensor,its not an abs sensor but the sensor on the box, I have rung Bearmach and they say there are 2 on the box but im not sure which one to change? any ideas?

thanks for the reply,

Simon.

Link to comment
Share on other sites

Hi Ian, you'll find lots of helpful people on this forum, I am pretty new myself.. from what I have read on other posts it may be a problem with the cables between shifter and the box, you can adjust it but would probably create your own post on here and ask for help. sorry I cant be of more assistance...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership