Jump to content

holding back


ant62
 Share

Recommended Posts

need some help and advice please, my xtype seems to be holding back at 60mph it starts goes through all gears and seems spot on until i reach 60, i have no warning lights or any signs anythings wrong, until i opened the bonnet i have oil all over the drivers side inner wing, to hot to investigate at moment, any ideas would be helpful hopefully nothing serious as although its holding back its not going into limp mode. TIA

Link to comment
Share on other sites

replaced the air intake pipe with a new silicone one what a difference, worst part was getting the lower pipe clamp tightened i took of the egr that made it easy to get my chunky arm down there

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership