Jump to content

Drive Shaft ......help!


Marlowboy
 Share

Recommended Posts

Hi all, I’m sure I was a member on here with my XKR but can’t find myself, hey ho! Can anyone tell me what I am doing wrong.....S-type 3.0 rear N/S driveshaft removal as trying to change the Hub. All disconnected and I’ve now broken 2 Pullers trying to get the hub off the shaft, am I doing anything wrong? Any help much appreciated!

Link to comment
Share on other sites

hi

The drive shaft spline ia locktighted into the hub

you will need a 10 ton puller, thats what I used

get some pressure on the puller, then I used a soft drift, some aluminium bar and hit the driveshaft behind the hub, on the angled bit, dont hit the abs ring, as it will damage it, I gave it 2 good blows, then turned the driveshaft 90 degrees and kept going, after a good few blows, the tensioned dropped on the puller, apply more pressure on the puller and keep going till it comes off.

cheers

Joe

Link to comment
Share on other sites

And so it continues...... I’ve now managed to separate the Outer C.V. Joint from the Drive Shaft, just dropped the Hub at my local Agriculture/ Land Rover Specialist and they are going to try and press the joint out, but didn’t seem very hopeful! Worst senario is now another Second hand CV Joint so is that a glimmer I see in the tunnel?

Link to comment
Share on other sites

And so it continues Part Two! The LR Indy using his 10Ton Press has not moved it, I think it’s stuck! Ordered a CV Joint from a breaker so hopefully it will be plain sailing when it arrives......we shall see!

Link to comment
Share on other sites

hi

have they tried heat, heat will soften the lock tight on the splines

I used the type in the pic below, worked well for me, cheap pullers dont always work, the seals pop real easy, I use a sykes pickavant hydraulic rams and its been superb for years

hubba.thumb.jpg.aa694a9974845d1468f5fe20c695f976.jpg

DSC_0815ssss.thumb.jpg.4d3e74a59f51aa80539f394187e27680.jpg

spacer.pngspacer.png

Link to comment
Share on other sites

Thank you for your reply, sort of all done now........all back together and drove a couple of miles all fine. Started is this morning.......Abs Light has come on, wonderful! Up in the air again tomorrow then!

Link to comment
Share on other sites

Agggh...I hate cars.

could anyone help, I’ve got a replacement abs sensor but onlooking, the existing one does not seem to be fitting flush on the Hub and the same with the new one. It also seems the magnet is missing the sensor ring, mostly pointing at the cv gaiter edge. What could I have done wrong putting it all together. The Shaft Nut seems to be in the right place on the shaft.....any pointers please?

Link to comment
Share on other sites

Will this ever end.......received hub and.......it’s the same as the last one, wrong! Spoke to Breaker, very apologetic and has sent out to me the correct one, I hope, and should have it tomorrow......

 

Link to comment
Share on other sites

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership