Jump to content


Climate control fault. S Type


bjb
 Share

Recommended Posts

My 54 plated cars  climate control is blowing hot air on the passengers side but working normally on the drivers side. can anyone help with the probable cause?

Link to comment
Share on other sites

  • 2 weeks later...

If anyone has an answer to this one, it might help my dad. He has a Saab 9-5 (Y reg) that had the same, but was told it would cost him £500 in stripping out the fascia before any fault could be identified. As it happens, it seems to have righted itself since but if the problem recurs ....

Link to comment
Share on other sites

Hi

I think I may be able to help. The problem is probably with the connector that fits into the the heater control module, because of its position down the side of the radiator it is prone to corrosion and eventual failure, I have just had my 2005 S Type 2.7D cured of this problem, the connector wires if badly corroded or broken will give these symptoms, its what I experienced. A replacement connector can be obtained by using the brake master cylinder connector of a  scrap Ford Focus readily available & not in a position to be corroded, I had the new connector wires soldered on to the three wires after removing the connector from the harness wires on the Jag., result wonderful cold air on both sides of the system also hot as well if you require it

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share





×
×
  • Create New...



Forums


News


Membership