Aubrey

S Type is it overheating?

Recommended Posts

Hi,

 

My 1999 S Type it heats up very quickly to 1/2 way but stays there never goes any higher.

Even after a journey of a few miles and when I stop the Fan stays on for a while. 

I read the manual and I know it will continue to run for a while but is this normal after say 3 - 5 miles?

 

Thank you.

 

J

Share this post


Link to post
Share on other sites

Hi Julie,

 

I have a diesel S type, and do not expect the engine to heat up very quickly, although when it does it sits exactly halfway.  On the 1st July - that very hot Wednesday - I went down to Welwyn, 120 miles each way, and coming back I average about 55 mph and the needle never moved.  As normal when I got home I let the engine run for a minute while the turbos stopped spinning.

 

The fan does stay on a little while, but it used to do the same on my Rover irrespective of distance.

 

Regards,

 

Peter. 

Share this post


Link to post
Share on other sites

Good Morning Peter,

 

Thank you, I was just a little worried in case I did any damage to the engine.

 

Regards,

 

Julie.

Share this post


Link to post
Share on other sites

Good Morning, Julie,

 

As long as you use the best engine oil as recommended and have it changed once a year you engine should have no problems.  I also use Shell V Power, which keeps the engine clean, but not as important in a petrol engine as in a diesel as mine is.

 

Regards,

 

Peter.

Share this post


Link to post
Share on other sites

Thank you Peter. I will get some V power and give it a go.

 

I check the oil and water each week, it has not use any up to now. When I bought it In May it had just had a service so had nice fresh oil in it.

 

Kind Regards,

 

Julie.

 

 

Share this post


Link to post
Share on other sites

hi i got a jaguar s type v8 2001, it overheating it started by bursting the radiator pipes now the coolant resevor, the engine goes on normal after warming up air pressur starts to rise on the pipes leading to bursting the coolant resevor, any one pls help out

Share this post


Link to post
Share on other sites

hi

get a sniff test done at a garage, checks for carbon monoxide in the expansion tank

or compression test, but not always accurate

sounds like head gasket has started to fail

assume you've checked obvious like thermostat and water pump

every time ive seen this its always been head gasket

cheers

Joe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...