Jump to content

Satnav Update 2013 Sportbrake

Devil Blades

Recommended Posts

Have just started an update on my satnav in my 2013 sportbrake and came across a problem that did not seem to be documented anywhere else.

I started the update and all seemed ok and it got to 20% and I had to stop the car and turn it off but I thought that is ok as from other posts people say it just carries on from where it left off.

On restarting the car it came up on the screen with a message saying "Loading of map paused. Please insert disk to restart download." 

Even though it says disk it means the USB stick!!"

The only prompt on the touch screen was cancel and I did not want to risk pressing that as I was not sure if the activation code would work a second time around. So I pulled out the USB stick and reinserted it as the screen said but I still got the same message so I carried on and drove to work (30mins) when I got there it still had the same prompt so I turned it off and tried again still the same.

Then I decided to press the NAV button and low and behold the message cleared and the screen came back to normal and I could see it had been updating all along and was now on 30%.

So if you see the same message do not panic and just press the NAV button.

Will update post when it has finished.


Link to comment
Share on other sites

Well it updated and finished 100% but after turning the car off and leaving till next morning I now have a very sluggish satnav and no postcode option anymore also takes ages between button presses and a message comes up and saying "unable to perform the request Please try again" after pressing the Pick from Map Option".

Anybody got any ideas? 




  • Like 1
Link to comment
Share on other sites

There seems to be no way to go back to the previous working map set. 

For some strange reason it wrongly thinks the stick is now older when in fact it is the same stick and the same files that are now on the Hard drive in the satnav!!

Have had an email from them and they are sending me two more USB sticks one with Turkey Maps that I have to use first and then a Europe Map to sort out problem.

At least they have responded.

Lets hope it sorts the problem out.

Link to comment
Share on other sites

16 minutes ago, Manniewinaename said:

Hope it is not a virus.

I wonder if there is a site where you could first download to your laptop or desktop and then once virus scanned put to a usb to go in car.

When I got mine I Virus Scanned the USB Stick on my PC before installing it.  Installation went faultlessly but took 2.5 hours.

Link to comment
Share on other sites

  • 2 weeks later...

Well after many attempts it seems to have now installed ok!!


The Turkey map went on ok ( 38min ) and all the buttons appeared to work all be it for Turkish postcodes and addresses.

I then did a long drive with the Europe map and it came up with the map update paused message several times whilst driving and then when it did finish nothing worked again.


I attempted it again and it did the same whilst driving so I did it yet again but left the car ticking over for three hours until it said finished that time all was ok.


I was a bit worried when all I could select was Turkish postcodes but with the UK map showing until I found it was still set for Turkey as the search country.


This has to be the worst Sat Navigation system for updating the interface and ambiguous response messages or appalling.

Link to comment
Share on other sites

  • 2 years later...

Rather late to this thread but can you state where you got the update USB from please?

Following a journey from home to Oldham yesterday, it is clear there have been many road changes and I therefore need to update my 2013 XF.


  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Hi all I have a late 2013 xf sportbrake and this morning I noticed my sat nav was mapping a different country, tried going into menu and setting mapping to United Kingdom but it's staying on the foreign mapping which is Brussels!!! Anyone any tips or had similar issues and have a fix for this? Cheers Keith

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...