Jump to content

Climate control problem.


Raistlin
 Share

Recommended Posts

When I set temperature to "Lo", I get nice cold air from the passenger's vent but barely cool from the Driver's side.

Air con was serviced rencetly and is perfect.

I worked out that the driver's side temperature blend flap might be stuck in one position but observing the servo motor when changing temperature settings over the full range shows it to be moving end to end as it should do.

Anything else I should be considering please?

Link to comment
Share on other sites

Hi paul

its usually the dccv starting to fail and passing hot water

drivers and passenger side are seperate valves

are they both cold, when the engine is cold, if so, must be dccv passing

very common s-type fault

cheers

Joe

Link to comment
Share on other sites

  • 5 months later...

View all the latest Jaguar leasing deals here:

Limited Stock*for early 2022

*Due to the on-going semiconductor issues, the supply of new cars and vans has been dramatically hit. If you are due to change your vehicle/s in the next year or so you will NEED to start looking now to avoid disappointment or potentially being without a vehicle.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...



Forums


News


Membership