maximum velocity

Hazard light problem - wont switch off.

Recommended Posts

Hi got a jaguar xf 3.0D on a 10 plate, had it for 4 weeks now.

 

Strange problem just happened, car was parked outside, neighbour knocked the door to tell me my hazard lights were flashing, (No alarm had gone off) couldn't knock them off any way I tried so phoned jag assist who sent out an AA man who was on the line to jag assist guy.

 

Only way they were able to knock the lights off was to disconnect the battery and then reattach it. Basically a reset.

 

Got to take the car down to Jag in the morning to see what the problem is, just wondering if anyone else has had this problem.

Share this post


Link to post
Share on other sites

Hi Mark

 

not heard of this one before....let us know how you get on

 

Regards    Trevor

Hi Trevor.

It was a water leak travelling across some cross section into the rear junction/relay box (in the boot) causing corrosion on the contacts. They had to fix the problem where the water was coming in and replace the relay box. seems ok now fingers crossed.

Got the impression from the Jaguar Assist guy I phoned when this first happened, that he new what this fault was before he even saw the car. so he must have come across it before.

mark.

Share this post


Link to post
Share on other sites

Hi Mark

 

Thanks for letting us know what the problem was...and how it was rectified. Very useful for future reference!

With the amount of rain we have had just recently I'm not surprised its found its way into everywhere.

 

Regards    Trevor

Share this post


Link to post
Share on other sites
Quote

I just found this post when I net searched Jaguar XF hazard.... Seems like I may have the same issue, had a nightmare driving home yesterday with people flashing lights at me etc. because my hazards were on. Only I knew they wouldn't turn off .

 

Share this post


Link to post
Share on other sites

This happened to me today, hazards came on several times whilst driving. Only short-term remedy was pulling over & switching ignition off. Also, Eco stop-start has stopped working simultaneous to the hazard problem. I assume they are related faults. 

Share this post


Link to post
Share on other sites
On ‎12‎/‎4‎/‎2018 at 5:51 PM, MattG32 said:

This happened to me today, hazards came on several times whilst driving. Only short-term remedy was pulling over & switching ignition off. Also, Eco stop-start has stopped working simultaneous to the hazard problem. I assume they are related faults. 

Three days since this occurred, and, touch wood, no further problems. 

Keeping 'em crossed!

Share this post


Link to post
Share on other sites

This is happening to me right now. I am checking the sequences, but seems like the problem is triggered by locking on the door handle.

I have no idea what to do.

Alan Lloyd

Share this post


Link to post
Share on other sites

No! it has a mind of its own. If I leave the car unlocked they come on, If I lock they com. on and will not turn off. If they turn off they come back on later.

Share this post


Link to post
Share on other sites

Yep, the latest electrical fault for mine also. Hazards come on when I switch off the ignition, and only disconnecting the battery will stop it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...